Error in TypeScript compilation when upgrading to VS DEV15 and TypeScript 2

If you upgrade to TypeScript 2 (incidentally, done automatically by installing VS DEV15), you can get the following errors in a web project containing TypeScript files:

 

  • The "VsTsc" task could not be initialized with its input parameters.
  • The "OutputLogFile" parameter is not supported by the "VsTsc" task. Verify the parameter exists on the task, and it is a settable public instance property.
 
You need to open a Notepad as administrator and edit the file C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v15.0\TypeScript\Microsoft.TypeScript.targets, removing the OutputLogFile parameter.

 

Comments (2) -

  • Hi, I had the same error when upgrading to Typescript2. Found the solution was to install the updated Visual Studio plugin referenced here (in the TypeScript 2.0.3 section):

    https://github.com/Microsoft/TypeScript/releases
    • Thank you Matthew for your comment!

      So far I've used TypeScript only in Visual Studio DEV15 Preview 4, but I plan to upgrade it, because I was waiting that Visual Studio 2015 proposed me to do some update.

      From your link I've found the updated plug-in for Visual Studio 2015.

      Thank you!

Add comment

Loading